Subject: Re: Updating from 1.5_BETA to 1.5.1_ALPHA (lib conflicts)
To: Peter Losher <>
From: Todd Vierling <>
List: current-users
Date: 01/22/2001 14:29:56
On Sun, 21 Jan 2001, Peter Losher wrote:

: I have some NetBSD boxes where I originally installed 1.5_BETA on several
: months ago.  I tried updating to 1.5.1_ALPHA by 'cvs checkout
: -rnetbsd-1-5 src' and built a new kernel.  I rebooted under the new
: kernel, and started a make build:

: The following libraries have versions greater than the source:
: /usr/lib/

This machine has seen -current before you tried to go back to the 1.5
branch; the version of libc on the 1.5 branch is 12.62 (and now 12.62.1).
Your libc 12.64 is post-1.5 branch.  Perhaps when you thought you installed
1.5_BETA, you really got "1.5B"?  Version 12.64 of libc existed in the
sources between 2000/07/08 and 2000/08/10, a little over a month.

You need to back the binaries on this machine down to 1.5.  Best suggestion
is to use the premade binary sets from your nearest mirror.

: /usr/lib/

Same deal.

-- Todd Vierling <>  *  Wasabi NetBSD:  Run with it.
-- NetBSD 1.5 now available on CD-ROM  --