Subject: mmap problems with LFS on -current
To: None <>
From: Feico Dillema <>
List: current-users
Date: 01/18/2001 22:21:19
Just setup an lfs filesystem to build from, but while reading and
writing to it goes ok tools that memory map files from it seem to
fail. Didn't find a PR on it. Is this a known problem? I am not
dependent on LFS, just wanted to try it out and thought reporting 
this here might be  helpful. Attached is a ktrace output from a simple


  1362 cmp      RET   read 4096/0x1000
  1362 cmp      CALL  mmap(0,0x93000,0x5,0x2,0x3,0,0,0)
  1362 cmp      RET   mmap 1208393728/0x4806a000
  1362 cmp      CALL  mmap(0x480ec000,0x5000,0x3,0x12,0x3,0,0x81000,0)
  1362 cmp      RET   mmap 1208926208/0x480ec000
  1362 cmp      CALL mmap(0x480f1000,0xc000,0x3,0x1012,0xffffffff,0,0,0)
  1362 cmp      RET   mmap 1208946688/0x480f1000
  1362 cmp      CALL  close(0x3)
  1362 cmp      RET   close 0
  1362 cmp      CALL  issetugid
  1362 cmp      RET   issetugid 0
  1362 cmp      CALL  open(0xbfbfd5c8,0,0)
  1362 cmp      NAMI  "Makefile"
  1362 cmp      RET   open 3
  1362 cmp      CALL  open(0xbfbfd5d1,0,0)
  1362 cmp      NAMI  ""
  1362 cmp      RET   open 4
  1362 cmp      CALL  __fstat13(0x3,0xbfbfd454)
  1362 cmp      RET   __fstat13 0
  1362 cmp      CALL  __fstat13(0x4,0xbfbfd3f4)
  1362 cmp      RET   __fstat13 0
  1362 cmp      CALL  mmap(0,0x179,0x1,0x1,0x3,0,0,0)
  1362 cmp      RET   mmap 1208995840/0x480fd000
  1362 cmp      CALL  madvise(0x480fd000,0x179,0x2)
  1362 cmp      RET   madvise 0
  1362 cmp      CALL  mmap(0,0x179,0x1,0x1,0x4,0,0,0)
  1362 cmp      RET   mmap 1208999936/0x480fe000
  1362 cmp      CALL  madvise(0x480fe000,0x179,0x2)
  1362 cmp      RET   madvise 0
  1362 cmp      PSIG  SIGSEGV SIG_DFL
  1362 cmp      NAMI  "cmp.core"