Subject: Re: Why my life is sucking.
To: Herb Peyerl <>
From: Manuel Bouyer <>
List: current-users
Date: 01/16/2001 21:59:04
On Mon, Jan 15, 2001 at 03:18:15PM -0700, Herb Peyerl wrote:
>  > Manuel Bouyer <> wrote:
>  > > 	nlager# time mkdir foo
>  > > 	0.0u 0.6s 0:17.72 3.8% 0+0k 3687+7io 0pf+0w
>  > 
>  > And is the machine hung during this time ?
> other disk accesses are blocked, yes.  I've confirmed that the parity is
> clean on the raid partition and that everything is otherwise idle.  I've
> also tried it with one of the components failed.  No change.  I built a
> regular filesystem on one of the components and untarred pkgsrc.tar.gz
> (my benchmark for reproducing this problem) and it literally screamed
> along and worked flawlessly.

Ok, I think this is definitively a raidframe bug.
Silly idea: could you try to slow down your machine and see if you can
reproduce it (disable caches in BIOS for example). Yes, I think this can
be timing related :)
Raidframe/raid1 works fine for me on a bunch of machines, exept the minor
annoyance on the alpha I reported, which looks similar to your problem. But
now that I think about it, the alpha could really be the fastest machines of
all the ones I have with raidframe (it competes with a PIII/700 but the
alpha is clearly superior in I/O ...), but your 800Mhz machine with recent IDE
disks may be a bit faster than my alpha.

>  > > dump 0f - /dev/rraid1a | ( cd /mnt ; restore -if - )
>  > > [...]
>  > > I've duplicated this 3 times and each time the same files don't get copied. I
>  > > illustrate with /sbin as an example but the lossage is everywhere.  My 1G
>  > > /home partition is different by about 100MB between /home and /mnt/home.
>  > 
>  > Is the filesystem you copy mouted ? Maybe a mounted partiton, with some
>  > activity, could produce problems like that. With softdep it could even be
>  > worse.
> /dev/rraid1a is my root filesystem.  The system is otherwise quiescant. In
> fact, I can reproduce the problem in single-user mode.  I don't have 
> softdep enabled.

With rraid1a mounted RO ?

>  > > 	Non-unique normal route, mask not entered<3>Non-unique normal route, ma
>  > sk not entered<3>Non-unique normal route, mask not entered
>  > > 
>  > Seems to be from net/radix.c. Is your network config sane ?
>  > An ipv6 problem, maybe ?
> My network config is sane as far as I'm aware:
> 	fxp0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
> 		address: 00:d0:b7:26:ab:f8
> 		media: Ethernet 100baseTX
> 		status: active
> 		inet netmask 0xffffff00 broadcast
> 		inet6 fe80::2d0:b7ff:fe26:abf8%fxp0 prefixlen 64 scopeid 0x1
> Greg Oster suggested my problems with dump/restore leaving out files might
> be related to the files that have been left out are all ones that have hard
> links.  ie: mount_ufs, newfs, swapctl, swapon, etc.

I can't reproduce this either ...
Did you try to dump to a file, and then restore from that file ?

Manuel Bouyer <>