Subject: LFS & UBC problems
To: None <>
From: Manuel Bouyer <>
List: current-users
Date: 12/13/2000 19:30:30
I tried a UCB kernel on my developement machine, which has sources (I don't
use objdirs) on LFS.
Then I tried a 'make build', but it fails with:
Build started at: Wed Dec 13 17:47:13 MET 2000
(cd /home/ && make -m /home/ DESTDIR=/ distrib-dirs)
install  -d -o root -g wheel -m 755 /
mtree -def mtree/NetBSD.dist -p // -u
cd /; rm -f sys; ln -s usr/src/sys sys
(cd /home/ && make install)
install -r  -c   -o root  -g wheel  -m 444  bsd.README /usr/share/mk/bsd.README
install: /usr/share/mk/inst.00268a: Bad address
*** Error code 1

*** Error code 1


A ktrace shows that install mmaps bsd.README, and use write(2) with
the mmap'ed area as argument to copy it to /usr/share/mk/inst.00268a

Similarly, a 'tail -f' of a file on the LFS dumps core, because it mmaps
the file and get a SEGV when trying to access the mmaped area.

Anyone else seen this ?

Manuel Bouyer, LIP6, Universite Paris VI.