Subject: Re: UBC vs lfs and union mount
To: Chuck Silvers <>
From: Geoff Wing <>
List: current-users
Date: 12/05/2000 19:42:54
Chuck Silvers wrote about Re: UBC vs lfs and union mount:
:On Mon, Dec 04, 2000 at 07:18:36AM +0000, Geoff Wing wrote:
:> before update: (expected) wrong output
:> after update: works on ffs, segv's on lfs, segv's on union mount.
:I've added this to the list of things I broke.  :)

Yes, thanks, I found your message to tech-kern (back when you wanted
testers) and didn't see those in the list of supported file-systems so
I presumed (hoped) they were being worked on (since I use union mounts
and lfs rather heavily sometimes).

:> Other programs also have some problems on lfs and union mounts, or
:> moving between them and other file systems.
:could you be more specific?  which programs and what problems do they have?

Might be more related to the previous problem: due to mmap support?
% mount_union /obj /usr/src && cd /usr/src && make includes
includes ===> include
Segmentation fault
install -r   -c  -o bin -g bin -m 444 a.out.h  /usr/include/a.out.h
install: /usr/include/inst.00725a: Bad address
*** Error code 1

*** Error code 1

However I can cd into lib and build those OK (well, seems to build OK though
I didn't check if it built correctly).  There were a couple of other things
I tried similarly with lfs.

Geoff Wing : <>
Rxvt Stuff : <>
Zsh Stuff  : <>