Subject: /usr/lib/c++rt0.o and 1.5_BETA
To: None <>
From: Jeremy C. Reed <>
List: current-users
Date: 10/26/2000 15:51:25
(Is the current-users the appropriate list for submitting 1.5_BETA issues?
Or should I just use the bug-tracking system? I am still unclear about the
differences between "current", 1.5 and 1.4Z. Are there really
separate/un-related projects being worked on?)

I believe /usr/lib/c++rt0.o is missing or wrong in the i386 1.5_BETA.

I untarred the 1.5_BETA sets directly over my 1.4.2 installation (on
i386). When I do a make in pkgsrc/graphics/tiff, I receive the following:

*** Warning: inter-library dependencies are not known to be supported.
*** All declared inter-library dependencies are being dropped.
*** The inter-library dependencies that have been dropped here will be
*** automatically added whenever a program is linked with this library
*** or is declared to -dlopen it.
/usr/bin/ld -Bshareable -o .libs/  tif_aux.lo tif_close.lo
tif_codec.lo tif_compress.lo tif_dir.lo tif_dirinfo.lo tif_dirread.lo
tif_dirwrite.lo tif_dumpmode.lo tif_error.lo tif_fax3.lo tif_fax3sm.lo
tif_getimage.lo tif_jpeg.lo tif_flush.lo tif_luv.lo tif_lzw.lo tif_next.lo
tif_open.lo tif_packbits.lo tif_pixarlog.lo tif_predict.lo tif_print.lo
tif_read.lo tif_swab.lo tif_strip.lo tif_thunder.lo tif_tile.lo
tif_unix.lo tif_version.lo tif_warning.lo tif_write.lo tif_zip.lo
-R/usr/pkg/lib /usr/lib/c++rt0.o
/usr/lib/c++rt0.o(.text+0x16): undefined reference to
/usr/lib/c++rt0.o(.text+0x4e): undefined reference to
/usr/lib/c++rt0.o(.text+0x84): undefined reference to
/usr/lib/c++rt0.o(.text+0xb4): undefined reference to
*** Error code 1

My current file is:
-r--r--r--  1 root  wheel  523 Jul 15  1999 /usr/lib/c++rt0.o

But I think it was already installed before my upgrade. I can't seem to
find /usr/lib/c++rt0.o in any of the *.tgz sets.

I read a few messages about c++rt0.o in regards to a pkgsrc version -- but
it only appears to be for sparc.

So I rebuilt it and now it works (I could successfuly compile tiff):

 rainier:/home/src/lib/csu/c++$ make install

$ ls -l /usr/lib/c++rt0.o /usr/lib/c++rt0.o-SAVE
-r--r--r--  1 root  wheel  1418 Oct 26 15:43 /usr/lib/c++rt0.o
-r--r--r--  1 root  wheel   523 Oct 26 15:43 /usr/lib/c++rt0.o-SAVE

   Jeremy C. Reed