Subject: Re: Solved? Re: Serious trouble with ep driver on 1.5 branch (and 1.4.3).
To: None <>
From: Feico Dillema <>
List: current-users
Date: 10/21/2000 20:12:52
On Fri, Oct 20, 2000 at 09:53:34AM +0100, David Brownlee wrote:
> On Thu, 19 Oct 2000, Feico Dillema wrote:
> > Adding the following to my kernel config file:
> >
> > options         PCIC_ISA_ALLOC_IOBASE=0x2a0
> > options         PCIC_ISA_ALLOC_IOSIZE=0x060
> > options         PCIC_ISA_INTR_ALLOC_MASK=0xb88f
> >
> > makes my problem go away for NetBSD-1.5 (and probably also 1.4.3, not
> > tried). I don't need these on NetBSD-1.4.2. (I need these when I want
> > to use *two* pcmcia 3com ethernet cards in one laptop). I must say
> > that I don't understand why this fixes the problem for 1.5 (or which
> > option really fixes it; I guess the INTR MASK, but...) and why it is
> > not a problem for 1.4.2. I'll send my experiences in for the NetBSD
> > laptop FAQ, but if any of you could add some rationale to it that
> > might be nice). I'm happy again now, but I think it would be nice to
> > fix this, so that installing NetBSD-1.4.3 and NetBSD-1.5 works for
> > such machines and cards again. Work around is to use NetBSD-1.4.2
> > install floppies to install 1.4.3 or 1.5.
> 	Just to clarify the above - do you need them under 1.4.2 when
> 	you use two 3com cards, or 1.5?
AFAIK, under both. But it has been some time ago I first tried using two of
these cards in one laptop. Then I used NetBSD-1.4X, and I couldn't get
one card on 0x330 and the next on 0x340. The second wouldn't
configure. I tried many different iobase's (set them with 3com
install.exe tool and corrospondingly in NetBSDs kernel config), and
ended up with 0x2a0 for the first, and 0x2b0 for the second as a
working solution. If I remember correctly, I did pretty much an
exhaustive search on all possibilities there. I assumed this was a
3com/laptop quirk, not a NetBSD one. For both 1.4.2 and 1.5 the second
card doesn't configure with a GENERIC kernel. With the above options
and configering the cards corrospondingly with the 3com config tool,
it always works. 

Note however that I think this time (for 1.4.2 and 1.5) I haven't
bothered testing whether the second card would actually configure
if I used the 3com config tool to set its iobase at 0x340 (instead of
0x330, the default). 

> 	How is the attach/irq used reported differently between the#
> 	working and non working config under 1.5?

* non-working (1.5_ALPHA2 or GENERIC from latest 1.5 source):

configures at: 0x400 - 0x40f 
after ifconfig up: irq 10

* one card working (1.4.2 GENERIC/INSTALL):

ep0 configures at: 0x330 - 0x33f, irq 11

* both cards working (latest 1.5 source with above options):

ep0 configures at: 0x2a0 - 0x2af
after ifconfig up: irq 15
ep1 configures at: 0x2b0 - 0x2bf
after ifconfig up: irq 11