Subject: Webgear on Thinkpad 535
To: None <>
From: Pawel Rogocz <>
List: current-users
Date: 10/20/2000 09:35:11

I have three different machines that I am using NetBSD and Webgear
adapters on. Just recently tried NetBSD on Japanese IBM Thinkpad 535.
I got this message - "can't alloc shared memory" and ray0 was not
recognized. Other PCMCIA LAN adapters work just fine (tried Xircom
10/100). Any ideas ?

Here are the relevant lines from dmesg.boot

NetBSD 1.5_ALPHA2 (PAWEL) #4: Thu Oct 19 22:27:10 PDT 2000
cpu0: Intel Pentium (P54C) (586-class)
total memory = 40576 KB
avail memory = 34596 KB
BIOS32 rev. 0 found at 0xfda80
PCI BIOS rev. 2.1 found at 0xfdac0
pcibios: config mechanism [1][x], special cycles [1][x], last bus 0
pcibios_get_intr_routing: function not supported
No PCI IRQ Routing information available.
mainbus0 (root)
pnpbios0 at mainbus0: nodes 15, max len 83
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o space, memory space enabled
pchb0 at pci0 dev 0 function 0
pchb0: Intel 82437MX Mobile System Controller (MTSC) (rev. 0x02)
pcib0 at pci0 dev 1 function 0
pcib0: Intel 82371FB PCI-to-ISA Bridge (PIIX) (rev. 0x02)
pcic0 at pci0 dev 19 function 0: Cirrus Logic PD6729 PCMCIA controller
pcic0: controller 0 (Cirrus PD672X) has sockets A and B
pcic0: controller 1 (Intel 82365SL Revision 1) has no sockets
pcmcia0 at pcic0 controller 0 socket 0
pcmcia1 at pcic0 controller 0 socket 1
biomask efe5 netmask efe5 ttymask ffe7
pcic0: using irq 5 for socket events
ray0 at pcmcia1 function 0: WebGear, PC Card WLAN Adapter, Version 5.63
May 1999
: can't alloc shared memory