Subject: Solved? Re: Serious trouble with ep driver on 1.5 branch (and 1.4.3).
To: None <>
From: Feico Dillema <>
List: current-users
Date: 10/19/2000 13:38:28
On Mon, Oct 09, 2000 at 01:54:38PM +0200, Feico Dillema wrote:
> On Wed, Oct 04, 2000 at 03:33:54PM +0200, Feico Dillema wrote:
> > 
> > I very strange behaviour when trying to install and run
> > NetBSD-1.5_ALPHA2 (and latest kernel on 1.5 branch) on an old
> > 486 laptop. Initially I expected hardware trouble, but I think I
> > reuled that one out (tried three different machines and three network
> > cards. Also, installing with 1.4.2 bootfloppies goes just fine).
> Looking at dmesg output, both NetbSD-1.4.2 and 1.5 attach the pcimcia
> ep card at I/O port 0x400. This seems incorrect to me. NetBSD-1.4.2 
> places it correctly at port 0x330. I hope this narrows the problem
> area down a bit. Any ideas? Things I should test or try?

Adding the following to my kernel config file:

options         PCIC_ISA_ALLOC_IOBASE=0x2a0
options         PCIC_ISA_ALLOC_IOSIZE=0x060
options         PCIC_ISA_INTR_ALLOC_MASK=0xb88f

makes my problem go away for NetBSD-1.5 (and probably also 1.4.3, not
tried). I don't need these on NetBSD-1.4.2. (I need these when I want
to use *two* pcmcia 3com ethernet cards in one laptop). I must say
that I don't understand why this fixes the problem for 1.5 (or which
option really fixes it; I guess the INTR MASK, but...) and why it is
not a problem for 1.4.2. I'll send my experiences in for the NetBSD
laptop FAQ, but if any of you could add some rationale to it that
might be nice). I'm happy again now, but I think it would be nice to
fix this, so that installing NetBSD-1.4.3 and NetBSD-1.5 works for
such machines and cards again. Work around is to use NetBSD-1.4.2
install floppies to install 1.4.3 or 1.5.