Subject: Re: Serious trouble with ep driver on 1.5 branch (and 1.4.3).
To: None <>
From: Feico Dillema <>
List: current-users
Date: 10/09/2000 13:54:38
On Wed, Oct 04, 2000 at 03:33:54PM +0200, Feico Dillema wrote:
> I very strange behaviour when trying to install and run
> NetBSD-1.5_ALPHA2 (and latest kernel on 1.5 branch) on an old
> 486 laptop. Initially I expected hardware trouble, but I think I
> reuled that one out (tried three different machines and three network
> cards. Also, installing with 1.4.2 bootfloppies goes just fine).

Just some more data on this problem. I have tried NetBSD-1.4.3_ALPHA
also on these machines and see similar behaviour (although no panics
sofar) but throughput is close to zero, most of the time about 8KBs.
NetBSD-1.4.2 does *not* have this problem.

Looking at dmesg output, both NetbSD-1.4.2 and 1.5 attach the pcimcia
ep card at I/O port 0x400. This seems incorrect to me. NetBSD-1.4.2 
places it correctly at port 0x330. I hope this narrows the problem
area down a bit. Any ideas? Things I should test or try?