Subject: Re: odd pppd problem (1.4.1)
To: None <>
From: Wolfgang Rupprecht <>
List: current-users
Date: 10/07/2000 00:52:11 (John F. Woods) writes:
> After pppd has run for a while, it sometimes declares an LCP ECHO link
> failure ("Serial link appears to be disconnected.") and hangs up and
> redials (I have a 24x7 modem link).  About 30 seconds later, it
> declares the link dead AGAIN ("Serial link appears to be
> disconnected.") and hangs up and redials AGAIN, over and over again
> until I kill the pppd daemon and re-start it.  I have the LCP echo
> frequency set to 30 seconds with a failure count of 6 -- so 30 seconds
> should not be enough time to discover a failed link.

^S/^Q problems at either the modem side or the ppp side?
"+++" tripping up the modem?

I just had the unexpected pleasure of using PPP over the 56k modem on
my vaio portable for the last 7+ days while Athome/AT&T/TCI were
smearing chicken blood on the routers to drive out the evil spirits.
(Or at least thats what I got out of the explanation that the "tech"
support people gave me.)

I would notice times when the PPP connection only stayed up for a few
minutes, but I never saw times when the PPP had to be killed and
restarted before it would talk again.  This was a shared dialup so I
would kill the daemon every few hours when I wanted the connection to
stay down for a while.  (So the daemon never got really old.)
BTW. This running -current.

As it was, NetBSD-current was flexible and robust enough that I could
just point the default route from my main router / workstation at the
vaio portable.  On the vaio I ran a NAT, a gif ipv4-ipv4 tunnel, pppd
in demand-dial mode.  It all just worked.  I was also pleased to see
that the pppd was smart enough to ask for its old IP address back when
it called back.  Neat!

       Wolfgang Rupprecht <>
Coming soon: GPS mapping tools for Open Systems.