Subject: Re: HP 1533A DAT drive & Compression
To: Bill Dorsey <>
From: Matthew Jacob <>
List: current-users
Date: 10/01/2000 00:23:27
probably the NetBSD driver is using the wrong mode page.

On Sun, 1 Oct 2000, Bill Dorsey wrote:

> Hi,
> I was wondering if anyone has successfully used an HP 1533A
> DAT drive with compression turned on.  I've filled a 4 gig
> tape 5 times today and every time NetBSD reports the tape is
> full at the 4 gig point.  I'm using a 4-gig native capacity
> DDS-2 tape (should give up to 8 gig compressed capacity).
> I'd hope to get better than 1:1 compression on my ufs filesystem.
> I tried setting the DIP switches on the HP drive to force
> compression on.  I tried various recommended switch settings
> from HPs web site (which contains very spotty information on
> this drive -- shame on HP) for various operating systems
> including Sun 4.x, SGI, generic PC, and DEC.  I also tried
> messing with the NetBSD mt command.  If I have the compression
> hard-wired on, mt compress 1 fails, but mt compress 0 succeeds.
> If I have the switches set to allow the computer to select
> compression, then mt compress 1 succeeds.  When I do an mt
> status after the mt compress, it always comes back with the
> same thing (and reports the density is 36 -- DDS-2).
> If anyone has any suggestions for other things to try, I'd love
> to hear about them.  It would be nice if there were a simple
> way to determine whether compression was working or not without
> filling a tape (I will use 1.3 gig tapes from now in in my
> experiments until I get this working).
> BTW, the hardware is a DEC PWS 433a (Alpha) running NetBSD 1.4Y.
> --
> Bill Dorsey      "The unarmed man is not just defenseless --
>   he is also contemptible."  Machiavelli