Subject: very mysterious PCMCIA ne0 bug.
To: None <>
From: Todd Whitesel <>
List: current-users
Date: 08/29/2000 18:31:52
I am trying to get a new attachment working and it mostly works but not quite.

I have two hpcmips (Workpad z50) machines, and two models of ne0 card from
Socket Communications Inc:

Both are marked "LP-E". The first is a compactflash card and already works; I
have been using it since mid-March. It is already in pcmciadevs and has been
there since at least 1.4U.

The second card is called "LP-E Plus" on the web site; its main differences
are that it is a Type II and has a bigger dongle to support both 10bT and
10b2 (coax). In fact I deliberately got that card for the ThinNet support,
so I could connect it to my SparcBook in hotel rooms without having to bring
a hub along. However this card is not listed in pcmciadevs yet.

I tried cloning the entry for the compactflash version:

product SOCEKT LP_ETHER_CF      0x0075 Socket Communications Low Power Ethernet CF

I also corrected the spelling. Ran Makefile.pcmciadevs, cloned the entry in
if_ne_pcmcia.c, and fixed it up to use the right product ID. It probed!

ne0 at pcmcia0 function 0 port 0x300-0x30f port 0x310-0x31f
ne0: Socket Communications Low Power Ethernet Ethernet
ne0: Ethernet address 00:c0:1b:00:93:4b

It appears to operate, but packet transmission barely works.
FTP performance is horrible (barely 10K/sec), and there are weird pauses
in interactive sessions; sometimes a telnet connection simply hangs.

Kernel was from -rnetbsd-1-5 -D 20000818-UTC.
Symptoms follow the Type II card around when I swap components.
So it is either my unit, or this model simply requires "extra help".

Hints please... I have no idea where to start looking to isolate what sort
of quirk entry might be needed for this card.

Todd Whitesel
toddpw @