Subject: Re: newfs_lfs is very quiet?
To: None <>
From: Geoff Wing <>
List: current-users
Date: 08/14/2000 20:00:00
Kevin P. Neal <> typed:
:I tried to create an LFS this weekend. I updated my disklabel (on a i386
:box) and then did a newfs_lfs on the partition. 
:After a brief pause I got a shell prompt. I don't have drive leds for this
:box, so I'm not very sure if it actually did anything. When I tried
:to mount the filesystem the kernel trapped with some sort of math
:error (I didn't write it down, sorry!). 

I wrote it down but I can't find it at the moment.  A _udivdi3 call, I think,
but don't remember at the moment where it came from.  Using my old LFS
partition, it crashed with a new kernel.  It crashed with a new kernel
and new lfs_cleanerd.  Using a new kernel, new lfs_cleanerd and newfs_lfs
on the partition and I'm back up and running.
I don't think newfs_lfs normally prints anything, but I can't check at
the moment since the dummy run fails for me:

% newfs_lfs -N /dev/rwd0g
newfs_lfs: /dev/rwd0g: seek: Bad file descriptor

Geoff Wing : <>     Work URL:
Rxvt Stuff : <>      Ego URL :
Zsh Stuff  : <>       Phone   : (Australia) 0413 431 874