Subject: USB on HiNote VP710 Laptop: "can't map i/o space"
To: None <>
From: Duncan McEwan <duncan@MCS.VUW.AC.NZ>
List: current-users
Date: 08/11/2000 16:39:27
I've just got access to a USB Zip drive so I tried it out on my desktop machine
(PIII) and got it working without problems.

Then I tried it on my HiNote laptop and couldn't get it to work, I think
because the USB bus is not detected/configured properly.  The dmesg output
from a boot of the laptop says

     uhci0 at pci0 dev 1 function 2: Intel 82371AB USB Host Controller (PIIX4)
     (rev. 0x01)
     uhci0: can't map i/o space

When I run the usbdevs command I get no output.

In comparison, on my desktop machine the dmesg output says

   uhci0 at pci0 dev 7 function 2: Intel 82371AB USB Host Controller (PIIX4)
   (rev. 0x01)
   uhci0: interrupting at irq 10
   usb0 at uhci0: USB revision 1.0
   uhub0 at usb0
   uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
   uhub0: 2 ports with 2 removable, self powered

and usbdevs shows (the zip drive isn't currently plugged in).

    addr 1: UHCI root hub, Intel

The kernel configuration is identical in this area for both machines, and
just says

     uhci*   at pci? dev ? function ?    # Universal Host Controller (Intel)
     usb*    at uhci?
     umass* at uhub? port ? configuration ? interface ?
     scsibus* at umass? channel ?

Has anyone managed to get USB working on a HiNote?