Subject: building sawfish/librep on NetBSD-ELF
To: None <>
From: NJ Verenini <>
List: current-users
Date: 08/05/2000 20:16:53
Interesting problem I noted while trying to get librep/sawfish build on
my NetBSD box (1.5_ALPHA).

It seems that libtool (1.3.4 I tried) doesn't understand that
inter-library dependencies can be supported on NetBSD. I picked up a
patch from a send-pr (reference pkg/10106) to libtool that fixed things

With the patch, I was able to get librep compiled. Evidently it expects
that libtool's .la stubs will have the "dlname" line filled out.
Unfortunately when building inter-dependent .so files, they get built as
.a instead. Hence, you get a "null dlname" error when rep tries to
build. This can be a little tricky to catch, as librep uses its own
(unpatched) libtool -- you have to force it to use the fixed one.

Another problem I ran into was hardcoded directories in executables'
shared library paths (via ldd). I think this is a libtool misbehavior as
well, as I see it with seemingly anything that uses libtool. Anyone have
an insight into that?

I have yet to check out the latest pkgsrc to see if these issues were
addressed or not, but judging from ml traffic (including one where some
guy from helixcode made pkgsrc entries for sawfish/librep) there has
been some motion on it.