Subject: Re: -current support for xircom PCMCIA cards?
To: Claus Andersen <>
From: Eric Fox <>
List: current-users
Date: 07/24/2000 18:42:14
I've had very good luck installing on one of these using both an install
floppy and CD by booting off the install floppy, and slicing/formating the
hard-drive, then exiting sysinstall and manually copying the install
kernel to the hard-drive.  You can then swap the floppy/CD drives, boot
the install environment from the hard-drive, and finish by installing the
sets from CD.

Of course, this was when we had a single boot-floppy install ... haven't
tried it recently with the current multi-floppy images.

  /\---/\  Eric J Fox
 /  o o  \
 \.\   /./ ---------------------------
    \@/    "Of course it runs NetBSD."

On Mon, 24 Jul 2000, Claus Andersen wrote:
> On Sun, 23 Jul 2000, gabriel rosenkoetter wrote:
> > I have a laptop (an IBM Thinkpad 760ED) in which there can be either
> > a floppy drive or a CD-ROM drive and which is incapable of booting
> > from CD-ROM (stupidity in the BIOS). 
> The 76x series came with a plastic box which enabled you to attach your
> floppy drive externally. That was how I got my 1.4.1 installed but I
> suppose you haven't got that gadget handy anymore?
> > Thus, I'd like to boot from a
> > floppy and be able to perform an ftp install... but I can't do that
> > unless the boot floppy configures the PCMCIA ethernet card I have
> > available, which even the 1.5_ALPHA snapshot's floppy doesn't seem
> > able to, which is pretty silly considering how old this card is. I
> > also have *no* other i386 machines available to build a boot floppy
> > with the proper PCMCIA support
> The install floppy usually configures PCMCIA correctly on 76x as you can
> see from the lines below (pcic0: controller 1 will have sockets when
> docked (with the proper dock :-)))
> > pcic0 at isa0 port 0x3e0-0x3e1 iomem 0xd0000 - 0xd3fff
> > pcic0: controller 0 (Intel 82365SL Revision 1) has sockets A and B
> > pcic0: controller 1 (Intel 82365SL Revision 1) has no sockets
> > Xircom, CreditCard 10Base-T, CE-10BC, 2.0/0008012302-011494 (manufacturer 0x0105, product 0x0108) function 0 not configured
> It seems that the Xircom card is not supported. Wether it is easy to get
> it working I am not the one to say but I'd suppose it could be handled 
> as a standard ne2000 clone.
> > I'd still like to get that PCMCIA card to work, though...
> Your PCMCIA seems to be running OK so it might be worth borrowing another
> card somewhere. When I had my 765L I was using a _very_ cheap D-Link DE-650
> which worked "out of the box" as I remember.
> > Any suggestions and help will be much appreciated...
> This was just my "real life" experience. Hopefully someone not so clueless
> can help you either getting the Xircom running or how to manually prep the
> disk.
> -- 
> Kind Regards,
> Claus Andersen