Subject: Zope on 1.5A?
To: None <>
From: Leonard Sitongia <>
List: current-users
Date: 07/18/2000 21:17:52

I'm running

NetBSD becker 1.5A NetBSD 1.5A (BECKER) #10: Sat Jun 24 22:26:15 MDT 2000     root@becker:/usr/src/sys/arch/i386/compile/BECKER i386

I would like to get Zope going, but I'm stumbling on threads for Python (1.5.2).
I got mit-pthreads going by modifying the configure configuration.  Still,
rebuilding Python doesn't seem to know about the installed threads.

The error:

gcc  -g -O2 -I./../Include -I.. -DHAVE_CONFIG_H -c ./threadmodule.c
./threadmodule.c:38: #error "Error!  The rest of Python is not compiled with thread support."
./threadmodule.c:39: #error "Rerun configure, adding a --with-thread option."
./threadmodule.c:40: #error "Then run `make clean' followed by `make'."
*** Error code 1
Any help here?  I reconfigured --with-threads, expecting it would use
the pthreads I installed.



==Leonard Sitongia