Subject: Re: 1.5Alpha pppd problems
To: None <>
From: Brook Milligan <>
List: current-users
Date: 07/18/2000 10:20:36
   > >> Why noauth?  I'm need authentication because I run pppd directly from
   > >> getty.  Could this be the problem?  How does the 1.5Alpha
   > >You want the client to authentify itself to the server, but not the server
   > >to the client, rigth ?
   > 	it looks to me that the default setting for pppd is changed somewhere
   > 	in pppd master distribution development, and old configuration without
   > 	explicit "noauth" chokes.  the easiest way to update configuration
   > 	file is to put "noauth" in /etc/ppp/options.  maybe we should document
   > 	the change somewhere, and/or put sample /etc/ppp/* somewhere.

   The master distribution was changed so that authentication of the peer
   is required. If you don't want this, or need this increased level of 
   security, then the 'noauth' keyword is required. 

Peer authorization (via CHAP) is exactly what I had implemented before
and what I want now.  The problem is that it worked fine for 1.4.2 but
not with 1.5Alpha (20000620). 

My 1.4.2 setup required reciprocal authorization in both directions.
Could the 1.5Alpha server be choking on having to authorize itself to
the 1.4.2 client?