Subject: broken?
To: None <>
From: Markus Kurek <>
List: current-users
Date: 07/16/2000 21:31:10

I don't know if this is just on my system (i386/1.5_ALPHA), 
but a build of openssh with tcpwrapper-support enabled
fails with this error: 

 ===> Building for openssh-2.1.1p3
cc -o ssh ssh.o sshconnect.o sshconnect1.o sshconnect2.o log-client.o
readconf.o clientloop.o -L.  -Wl,-R/usr/pkg/lib -L/usr/pkg/lib
-Wl,-R/usr/pkg/lib -L/usr/pkg/lib -L/usr/pkg/lib -L/usr/pkg
-R/usr/pkg/lib -R/usr/pkg -lssh -lopenbsd-compat -lz  -lutil -lcrypto 
/usr/lib/ undefined reference to `allow_severity'
/usr/lib/ undefined reference to `deny_severity'
collect2: ld returned 1 exit status

This works perfectly after replacing -lwrap with /usr/lib/libwrap.a

Markus Kurek