Subject: Odd DMA error on advansys card
To: None <>
From: James Chacon <>
List: current-users
Date: 06/25/2000 16:07:40
I just bought an advansys card along with an 18G IBM lvd drive.

I already have an ahc card in the system to deal with my older drives/cd/etc.
It's been working fine forever and still hums along with the new card.

The problem with the new card is this:

I was able to newfs the drive with 0 problems. However when I mount it and
then try to run iozone on it the system just starts scrolling kernel

adw0: DMA Error. Reseting bus

This is from a current kernel of about a week back.

I did some quick tests and the the exact DMA error is 


I've tried turning max ccb's way down but that doesn't do much. It seems to
be load related as I can try tar'ing a directory tree over and it will reset
after about 10-20 files come across.

Any ideas? This is an abit BP6 dual celeron motherboard with 2x500 cpu's on
it. I'm not overclocking anything and except for PNP OS set to No (I tried
yes as well just to check) it's pretty standard.