Subject: Switching to 1.4Z
To: None <>
From: Hal Murray <>
List: current-users
Date: 05/31/2000 01:37:08
I've got a pair of 400 MHz Celeron systems running 1.4Z.  Here is 
my status/glitch list from the install...

I used the snapshot and sources from a few days ago.  Thanks Jason.  
Nice timing. 

The new defered network buffer allocation code works great.  Thanks.  
(These machines have a lot of network cards.  With 1.4.2 they ran 
out of buffers so I had to build special floppys and a special kernel.  
The new code let me do the install with the normal floppies and then 
do useful work with the kernel it installed.) 

1.4Z supports the Promise Ultra66 IDE card.  (1.4.2 didn't.)  I've 
got a card with 2 disks on each of these systems.  It turns out that 
the disks on the Promise card are wd0 and wd1 and my old disks got 
moved up to wd2 and wd3.  Is that a bug or a feature?  (It took me 
a while to figure that out, but it's obvious if you look in the right 

The update option of the install recipe asked me which disk to use.  
I told it wd2.  It tells me it doesn't like wd0.  I didn't double 
double check that, but I did go through it twice.  Can anybody easily 
confirm it?  Should this be PR-ed? 

Since update didn't work, I tried an install.  (I didn't have anything 
important on the disk.)  That worked OK on wd2. 

I installed things via FTP.  The screen that shows the info it's 
collecting (host, dir, user, passwd) needs returns.  They are all 
on one line that wraps and has tabs that confuse things. 

Status so far...

I've got things put back together well enough to be trying my network 
tests.  No big surprises yet but I've got a couple of quirks to chase. 

Only one clock glitch so far:
  May 30 13:43:20 hgm80d ntpd[167]: time reset 15.640742 s
  May 30 13:43:20 hgm80d ntpd[167]: synchronisation lost
  May 30 14:06:58 hgm80d ntpd[167]: time reset -0.393921 s
  May 30 14:06:58 hgm80d ntpd[167]: synchronisation lost
I think that was during one of the "easy" parts of my testing so
I don't understand what happened.

I haven't sorted out the problems with my sleazy timing code, but 
I haven't worked on it much.  [Yes, my spin loop would keep a system 
from dropping into power saver mode, but it's user code and I only 
run it when I'm running network tests.] 

I haven't seen any transmit timeout messages from the fxp/82558 Ethernet 

I now see things like this in the log file.  I don't remember them 
from 1.4.2.  Is this new or did I not scan the old logs carefully 
enough?  Is some cron job looking at my disks?  Why?  .. 

  May 30 03:18:07 hgm80c /netbsd: wd0: no disk label
  May 30 03:18:07 hgm80c /netbsd: wd1: no disk label
  May 30 03:18:07 hgm80c /netbsd: wd3: no disk label

Updating the Miatas is high on my list.