Subject: Re: scsi hang
To: Wolfgang Rupprecht <>
From: Manuel Bouyer <>
List: current-users
Date: 05/27/2000 17:24:48
On Fri, May 26, 2000 at 12:25:32PM -0700, Wolfgang Rupprecht wrote:
> I've just experienced a string of scsi hangs with the message log
> indicating scsi tagged command timeout.
> The problem is I have 1 4gig scsi disk with flaky media that I only
> use for temporary storage while doing backups.  I normally newfs it
> and then mount it. This time I was in a rush and just mounted it.  I
> then started my "gtar -czf /flakydisk/backup.tar.gz".  When I dd-ed
> this file to tape the system hung.  I hit the reset button, rebooted
> and tried it again.  Same deal.  A third try and I just waited for a
> few minutes and the system did eventually come back.  I got a string
> of errors for "tagged command timeouts".  I then newfs-ed the flaky
> disk and tried the backup again.  This time it worked flawlessly.
> Clearly the problem was that the inodes got scrod in some manner.  I'm
> guessing that the disk driver tried to seek or read some non-existent
> disk sector.  I wonder why didn't this cause an immediate error?  It
> seems odd that this would gum up the works so badly.

Or the disk tried to access a bad block and got stuck on this.
The problem is that the timeout for a SCSI read/write is 60s.

Manuel Bouyer <>