Subject: scsi hang
To: None <>
From: Wolfgang Rupprecht <>
List: current-users
Date: 05/26/2000 12:25:32
I've just experienced a string of scsi hangs with the message log
indicating scsi tagged command timeout.

The problem is I have 1 4gig scsi disk with flaky media that I only
use for temporary storage while doing backups.  I normally newfs it
and then mount it. This time I was in a rush and just mounted it.  I
then started my "gtar -czf /flakydisk/backup.tar.gz".  When I dd-ed
this file to tape the system hung.  I hit the reset button, rebooted
and tried it again.  Same deal.  A third try and I just waited for a
few minutes and the system did eventually come back.  I got a string
of errors for "tagged command timeouts".  I then newfs-ed the flaky
disk and tried the backup again.  This time it worked flawlessly.

Clearly the problem was that the inodes got scrod in some manner.  I'm
guessing that the disk driver tried to seek or read some non-existent
disk sector.  I wonder why didn't this cause an immediate error?  It
seems odd that this would gum up the works so badly.

Unfortunately two different "3133t" twits tried so many different
probes in the last couple of hours that my 5 /var/log/message files
only go back for 8 hours and the scsi errors rolled of the end.
       Wolfgang Rupprecht <>
DGPS signals via the Internet