Subject: pppd
To: Michael G. Schabert <>
From: None <>
List: current-users
Date: 05/13/2000 10:44:29
>Umm, how can you say that that "didn't break it"? It certainly wasn't 
>broken hard, but it was broken. On "anything else like it"...I 
>decided to roll a kernel without the IPv6 functionality in it (paring 
>down unused options) and was hosed when I rebooted the kernel...The 
>kernel worked fine, but I work on my BSD box remotely with the BSD 
>box doing auto-dialin to my ISP. When I rebooted w/o v6 support, that 
>broke my pppd. I couldn't even use pppd with the noipv6 line in the 
>options file. That cut me off from the BSD box until I could get 
>there to access it locally. I consider that to be EXTREMELY broken.

	When did your pppd breakage happen??  Please report the breakage if
	there is.  Please.

	Timeline was like this:
	- I enabled IPv6 support in pppd
	- I got report of breakage
	- I bringed in part of more recent pppd, tested pppd with IPv4-only
	  kernel, it worked fine, and committed it
	so I think the latest pppd should work fine.  With the latest code
	pppd considres IPv6CP as optional.  To enable IPv6 negotiation you
	need explicit "+ipv6", and it should be compatible with old
	configuration file.  If the latest pppd is still broken, please report.
	(I guess you are using pppd during the breakage period, since you
	mention "noipv6" in the above)