Subject: speaking of sendmail...
To: None <>
From: Michael G. Schabert <>
List: current-users
Date: 05/12/2000 22:14:11
I emailed this to the list Tuesday, but it seems like it got lost somewhere...
Hi guys & gals,
This first part really means nothing to me, but I wanted to add it as 
a data point...I track -current & compile my own kernels & userland 
on my alphastation. Recently, I was going through my config file & 
tried turning off ipv6 (just for the heck of it). When I rebooted, I 
could no longer access my alpha...I access it across the Internet, & 
have it config'd to automatically dial into my ISP on bootup (it has 
static IP). When I got to where it is so that I could serial console, 
I saw that it wasn't stuck in the debugger, but rather pppd was 
complaining about the lack of IPv6, something about not being able to 
open an IPv6 connection...protocol not supported. I don't use IPv6 
for anything & don't know why it would be trying to access it to dial 
into the ISP. I tried putting nopiv6 into the options file, but it 
still didn't work, so I just rolled out another kernel with ipv6 

On the sendmail side...two questions. One is...does anything need to 
be turned on in sendmail for it to receive burstable MIME digests? My 
thoughts would be no, since an MTA shouldn't be concerned at all what 
is within the message, but should transmit it as is. But the one 
mailing list that I'm on that I receive in digest mode isn't being 
burst by Eudora (& I do have that setting turned on in EP prefs). 
That mailing list used to be burst but the list disappeared for a 
year or so, & has resurfaced using different servers, so I considered 
it to be an error on their end. When I emailed them about it, here 
was their response:

We are using Majordomo to distribute the list. It supports MIME 
formatting of the digest. The problem comes in from the mail server 
on your end. Some subscribers receive the digest just as you'd like 
to - as an attachment which can be opened in Eudora as a mailbox and 
see each individual message.

Unfortunately, there's nothing we can do on this end to "correct" the 
problem. I'd suggest talking with your provider and ask them to make 
sure their mail server is MIME enabled. My guess is they've done some 
type of upgrade and didn't set a MIME setting corretly.

Of course, I am "my provider" as far as mailservers are concerned, so 
I'm at an impasse. The only occurrance of MIME in my file 
is O SendMimeErrors=True. My second sendmail question concerns 
allowing it to act as an SMTP server for a domain that it doesn't 
serve. I already have it set up to serve mail for 2 additional 
domains using a file. I wish to be able to send mail from 
Eudora at home no matter where I dialed into, so I wish to add any 
other ISPs that I use to the list of sites that it will relay for (I 
moved into a different county from my main ISP & turned both the 
alpha and that ISP into a toll call). I tried adding the domain to 
the DS line, but my guess would be that that line is intended to be 
for something like ORBS.

(BTW...when did sendmail start wanting the .cf file to be in /etc/mail/ ?)

Thanks for your help,
Bikers don't *DO* taglines.