Subject: Re: Recent termcap changes
To: William O Ferry <>
From: Julian Coleman <>
List: current-users
Date: 05/04/2000 14:45:07
William O Ferry wrote:
> 	Thanks for the suggestions, the TERMCAP variable does not seem to
> have any effect on the problems I'm having, changing the one line in
> termcap.src is the only thing so far that seems to fix it.  I tried just
> setting TERM settings manually and verified that xterm-xf86-v32 seems to be
> where the real problem is (not too surprising since xterm and xterm-xf86-v33
> add very little to v32, but even if I set the TERM variable to v32 things
> go back to the failing state.  I really think things must be hosed in this
> termcap entry.

Hmm, just tried it here (v1.59) and it's fine.  Bold, reverse and underline
all work.  I see that there is no bell in vi - it flashes the screen instead.
This is because there is a 'vb' escape in the xterm-xf86-v32 entry and the
vi source (common/options.c) sets flash by default.  Perhaps bell should be
the default.  The problems you are having still seem like a truncated entry
to me.  Can you run the attached program (cc -ltermcap) and mail me the
results please?



                    My other computer also runs NetBSD
 ---8<---------------------------- Cut here ---------------------------->8---
#include <stdio.h>
#include <stdlib.h>
#include <termcap.h>

main(int argc, char *argv[])
	char	tent[1024];
	char	zz[32];
	char	*zzp;

	if (tgetent(tent, getenv("TERM")) < 1)
		errx(1, "No termcap entry\n");
	printf ("Truncated termcap is:\n%s\n", tent);
	zzp = zz;
	if ((zzp = tgetstr("ZZ", &zzp)) == NULL)
		errx(1, "No ZZ entry\n");
	sscanf (zz, "%p", &zzp);
	printf ("Full termcap is:\n%s\n", zzp);
	return (0);