Subject: ATI Rage128 with -current xsrc? (and wierd X crashes)
To: None <>
From: Rafal Boni <>
List: current-users
Date: 04/04/2000 08:48:01
Anyone use an ATI Rage128 with the NetBSD-current xsrc (cvs updated about a
week ago, if that matters)?  I can't seem to make things work 100% on the 
card, and sometimes I get pretty dramatic failures.

Problem 1:
	X comes up fine, but all text is either scramled (it looks like I'm
	using a bar-code font 8-), or is scrambled when highlighted (the
	TWM root menu comes up OK, but when any item is highlighted it turns
	into the same trash as above).

Problem 2: (the scary one)
	I thought this might be a problem with acceleration on the Rage not
	working right, so I attempted to add 'Options "no_accel"' to my X
	config file.

	The result was that X started up, switched VT's and blanked the screen
	and then locked the machine so the only recourse was to pull the plug
	out of the back... (The machine has no reset switch).  Other options
	I tried adding to the XF86Config seemed to do the same thing (I tried
	"sw_cursor", and "no_linear", then gave up).

I'm running -current as of last night on a Gateway E-5200 PC, which is a dual-
capable (BX chipset) intel motherboard with one 700Mhz PIII and 256MB RAM.  
The video card is a Gateway OEM's Xpert 128 (I believe) and works fine with
the Linux XFree86 3.3.6 server.  dmesg output is attached below


NetBSD 1.4X (CYCLOPS) #1: Tue Apr  4 04:09:09 PDT 2000
cpu0: family 6 model 8 step 1
cpu0: Intel Pentium III (E) (686-class)
total memory = 255 MB
avail memory = 234 MB
using 3296 buffers containing 13184 KB of memory
BIOS32 rev. 0 found at 0xfdb60
PCI BIOS rev. 2.1 found at 0xfdb81
pcibios: config mechanism [1][x], special cycles [x][x], last bus 1
PCI BIOS has 8 Interrupt Routing table entries
  device vendor product pin PIRQ   IRQ stage
000:07:2 0x8086 0x7112  D   0x03   09  0
000:17:0 0x9005 0x0010  A   0x01   10  0
000:18:0 0x1274 0x1371  A   0x02   05  0
000:19:0 0x10b7 0x9200  A   0x03   09  0
PCI bridge 0: primary 0, secondary 1, subordinate 1
PCI bus #1 is the last bus
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o space, memory space enabled
pchb0 at pci0 dev 0 function 0
pchb0: Intel 82443BX Host Bridge/Controller (rev. 0x03)
ppb0 at pci0 dev 1 function 0: Intel 82443BX AGP Interface (rev. 0x03)
pci1 at ppb0 bus 1
pci1: i/o space, memory space enabled
vga0 at pci1 dev 0 function 0: ATI Technologies product 0x5246 (rev. 0x00)
wsdisplay0 at vga0: console (80x25, vt100 emulation)
pcib0 at pci0 dev 7 function 0
pcib0: Intel 82371AB PCI-to-ISA Bridge (PIIX4) (rev. 0x02)
pciide0 at pci0 dev 7 function 1: Intel 82371AB IDE controller (PIIX4)
pciide0: bus-master DMA support present
pciide0: primary channel wired to compatibility mode
wd0 at pciide0 channel 0 drive 0: <QUANTUM FIREBALLP LM30>
wd0: drive supports 16-sector pio transfers, lba addressing
wd0: 28629 MB, 16383 cyl, 16 head, 63 sec, 512 bytes/sect x 58633344 sectors
wd0: 32-bit data port
wd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 4
pciide0: primary channel interrupting at irq 14
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2 (using DMA data transfers)
pciide0: secondary channel wired to compatibility mode
pciide0: disabling secondary channel (no drives)
uhci0 at pci0 dev 7 function 2: Intel 82371AB USB Host Controller (PIIX4) (rev. 0x01)
uhci0: can't map i/o space
Intel 82371AB Power Management Controller (PIIX4) (miscellaneous bridge, revision 0x02) at pci0 dev 7 function 3 not configured
ahc0 at pci0 dev 17 function 0
ahc0: interrupting at irq 10
ahc0: aic7890/91 Wide Channel A, SCSI Id=7, 16/255 SCBs
scsibus0 at ahc0 channel 0: 16 targets, 8 luns per target
eap0 at pci0 dev 18 function 0: Ensoniq AudioPCI 97 (rev. 0x08)
eap0: interrupting at irq 5
eap0: CRY19 codec; headphone, 20 bit DAC, 18 bit ADC, Spatializer 3D
audio0 at eap0: full duplex, mmap, independent
midi0 at eap0: AudioPCI MIDI UART
ex0 at pci0 dev 19 function 0: 3Com 3c905C-TX 10/100 Ethernet with mngmt (rev. 0x78)
ex0: interrupting at irq 9
ex0: MAC address 00:01:02:29:aa:5e
ukphy0 at ex0 phy 24: Generic IEEE 802.3u media interface
ukphy0: OUI 0x001018, model 0x0017, rev. 7
ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
lm0 at isa0 port 0x290-0x297: LM79
lpt0 at isa0 port 0x378-0x37b irq 7
pcppi0 at isa0 port 0x61
midi1 at pcppi0: PC speaker
spkr0 at pcppi0
sysbeep0 at pcppi0
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
npx0 at isa0 port 0xf0-0xff: using exception 16
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
isapnp0: no ISA Plug 'n Play devices found
apm0 at mainbus0: Power Management spec V1.2
biomask ed45 netmask ef45 ttymask ffc7
scsibus0: waiting 2 seconds for devices to settle...
ahc0: target 4 using 8bit transfers
ahc0: target 4 synchronous at 20.0MHz, offset = 0x8
cd1 at scsibus0 target 4 lun 0: <PLEXTOR, CD-R   PX-W124TS, 1.02> SCSI2 5/cdrom removable
ahc0: target 5 using 8bit transfers
ahc0: target 5 synchronous at 20.0MHz, offset = 0x10
cd0 at scsibus0 target 5 lun 0: <TOSHIBA, CD-ROM XM-6401TA, 1015> SCSI2 5/cdrom removable
IPsec: Initialized Security Association Processing.
boot device: wd0
root on wd0a dumps on wd0b
root file system type: ffs
wsdisplay0: screen 1 added (80x25, vt100 emulation)
wsdisplay0: screen 2 added (80x25, vt100 emulation)
wsdisplay0: screen 3 added (80x25, vt100 emulation)
wsdisplay0: screen 4 added (80x25, vt100 emulation)
wsdisplay0: screen 5 added (80x25, vt100 emulation)
wsdisplay0: screen 6 added (80x25, vt100 emulation)
wsdisplay0: screen 7 added (80x25, vt100 emulation)
wsmux1: connecting to wsdisplay0

Rafal Boni