Subject: Strange X11 keyboard problem (was: Re: kernel build failure 4/1/2000)
To: None <>
From: Johan Ihren <>
List: current-users
Date: 04/03/2000 15:51:59
Jason R Thorpe <> writes:

> On Sat, Apr 01, 2000 at 11:00:13AM -0800, Wolfgang Rupprecht wrote:
>  > cc  -O2 -Werror -Wall -Wmissing-prototypes -Wstrict-prototypes  -Wpointer-arith -Wno-main -I. -I../../../../arch -I../../../.. -nostdinc -I../../../../../crypto-us/sys -I../../../../../gnu/sys -DLKM -DDIAGNOSTIC -DTLP_MATCH_21040 -DTLP_MATCH_21041 -DTLP_MATCH_21140 -DTLP_MATCH_21142 -DNMBCLUSTERS=1024 -DAUDIO_DEBUG -DMAXUSERS=32 -D_KERNEL -Di386  -c ../../../../arch/i386/isa/pcvt/pcvt_drv.c
>  > cc1: warnings being treated as errors
>  > ../../../../arch/i386/isa/pcvt/pcvt_drv.c: In function `pcintr':
>  > ../../../../arch/i386/isa/pcvt/pcvt_drv.c:668: warning: implicit declaration of function `timeout'
>  > *** Error code 1
> Okay, this file compiles again, at least.
> Can I ask why people are still using pcvt?  I mean, we'd like to be able to
> nuke that console driver completely from orbit.

In my case (I filed a PR for this particular problem last friday) I
used (past tense) pcvt because I have ugly problems with X11 losing
the ability to react on keyboard entry intermittently. And while
trying to get a handle on that problem (ie. whether it might be
related to wscons vs. pcvt) I've kept one machine in pcvt land.

This last machine has now switched over to wscons, but, as expected,
my X11 keyboard problem crept along with it. Unfortunately.


PS. Short summary of our keyboard problem:

* i386 -current (from around 1.4P and onwards). But I'm not saying it
  started there, only that WE started there.

* Intermittently the keyboard "hangs". Only in X mode.  Most often the
  "hang" implies "no input", but sometimes it hangs in an endless
  repeat of the last key pressed. Shooting down the X server (from
  another machine) fixes it (at a certain cost). When "dead" switching
  virtual terminal doesn't work (no surprise).

* We've switched between pcvt and wscons, tried different versions of
  X (at least 3.3.5 and 3.3.6, don't know about 3.9.X or 4.0). We've
  tried a multitude of different keyboards (from old junk to brand new
  Logitech Cordless).

* In a typical hang the Xserver busy-waits over its select() call,
  reads zero bytes from an fd (presumably keyboard and/or mouse
  events) and then back to select().

* We have about a dozen machines exhititing this behaviour.
  Unfortunately all but one are lab machines that are booked solid for
  courses all the time. These machines only run NetBSD when I/we hold
  our courses there, so its not a constant problem, but it makes it
  difficult to play with them. The last one is my personal box and is
  the one that has tried most

* I haven't send-pr'd this because I cannot really categorize it. Too
  many variables. Unknown to everyone else I've talked to. Strange.