Subject: Re: cdrecord on scsi cdr with atapi cdrom
To: Erik Bertelsen <>
From: Manuel Bouyer <>
List: current-users
Date: 03/07/2000 10:28:37
On Mon, Mar 06, 2000 at 11:45:51PM +0100, Erik Bertelsen wrote:
> Recently I asked about using cdrecord on my NetBSD/macppc-current,
> because it would not open the SCSI library.
> Today I played with it again with the updated pkgsrc cdrecord-current.
> After having added SCSIDEBUG to the kernel and tried to find out whether
> the configuring of the cd record actually completed, I observed that
> cdrecord caused activities on my CD-ROM (cd0 on atapibus) when I tried to address
> the recorder (cd1 on scsi). I don't know why.
> I also observed that cdrecord dev=/dev/rcd0c -prcap would actually print
> the capabilities of the cdrom drive.
> I then removed 'cd* on atapibus...' from the kernel, and voila, now
> cdrecord can see and query the cd recorder (now on cd0). It is now
> happily blanking a CD-RW.

Could you try to hardwire your SCSI cd on cd0 and atapi cd on cd1 (with
kernel config file:
cd0 at scsibus? target ? lun ?
cd1 at atapibus? drive ?)

This would tell us if it's just because the unit number is not 0 that
it doesn't work ...

Manuel Bouyer, LIP6, Universite Paris VI.