Subject: Re: Sendto failure
To: None <>
From: D'Arcy J.M. Cain <>
List: current-users
Date: 03/04/2000 19:46:09
Thus spake darcy
> I have a little script that calls snmpget from the ucd-snmp pkg in the
> pkgsrc collection.  It has been working fine for months.  Yesterday I
> updated my kernel to the latest (1.4T) and rebuilt the world.  Now
> whe I run it I get a "snmpget: Failure in sendto (Address family not
> supported by protocol family)".  I have tried rebuilding everything -
> kernel, userland, ucd-snmp - and still I get the error.  On another
> system I did the same from the same sources and it works fine.  When
> I copy the libs and the binaries over to the other system the same
> program and libraries that worked on one fail on the other.  It sure
> seems to be in the sendto function except that no other program seems
> to be having the same problem.
> I use sup to pick up sources and I picked up the latest on both systems
> this morning so both should be the same.  Can anyone think of any
> reason why I would get this error all of a sudden?

Two weeks later and upgraded to 1.4U and this still happens.  I don't
get it.  Someone suggested that you get that error if you have the wrong
command line but this is in a script that has been running flawlessly
for months up to now.  In any case, here is the command in case anyone
sees something wrong with it.

snmpget -q -v 1 <machine@domain> <password> interfaces.ifTable.ifEntry.ifInOctets.17423

without any options I get the same error.

D'Arcy J.M. Cain <darcy@{druid|vex}.net>   |  Democracy is three wolves                |  and a sheep voting on
+1 416 425 1212     (DoD#0082)    (eNTP)   |  what's for dinner.