Subject: Re: ^W killed my line
To: None <>
From: der Mouse <mouse@Rodents.Montreal.QC.CA>
List: current-users
Date: 03/02/2000 02:20:19
>> [dsuspc]

> if it does what i think it does (send a tstp to a process when it
> next asks for input),

Basically, yes - it's just like suspc, except that suspc takes effect
when it's typed, whereas dsuspc takes effect when some process tries to
read it.

> then i think solaris has it working the way you expect.

Interesting.  Sun must have fixed it - I just now tried SunOS 4.1.4 and
it didn't do diddly.  ("sleep 5; cat" and type the dsuspc...nothing
happens when the sleep expires.)

And "Solaris" doesn't have it working, though perhaps some of the more
modern Solarices do.  (And no, I'm not quibbling about SunOS being
retconned to Solaris 1.x.)  I just now tried it on a machine running,
according to uname -a, SunOS 5.5.1 (ie, Solaris 2.5.1), and it failed
same as on SunOS 4.1.4.

					der Mouse

		     7D C8 61 52 5D E7 2D 39  4E F1 31 3E E8 B3 27 4B