Subject: Re: I must be doing something wrong...
To: John Darrow <>
From: Peter Seebach <>
List: current-users
Date: 02/17/2000 23:06:35
In message <>, John Darrow writes:
>In article <>,
>Yes.  I've been building in a /var/src, union mounted over a clean
>source tree, no obj dirs.  Here's the relevant part of my /etc/mk.conf:


Now I'm mystified.

Oh, boy.

Now I'm even *more* mystified.

It worked this time.  I made an object directory, ran make, and it worked.

I removed the object directory.

It worked anyway.

No idea what was happening; I didn't replace or update any files.

Here's the cool part:  I noticed that I have, dated as of today,
'libtelnet_pic.a' in /usr/src/domestic/lib/libtelnet.

If I remove it, libtelnet builds correctly, with or without an obj dir.

The question is, what caused it to get made?  Hmm.

# cd /usr/src/domestic/lib
# ls -l */*.a
-rw-r--r--  1 root  wheel   96548 Jul 11  1999 libntp/libntp.a
-rw-r--r--  1 root  wheel  104530 Jul 11  1999 libntp/libntp_p.a
-rw-r--r--  1 root  wheel  101024 Jul 11  1999 libntp/libntp_pic.a
-rw-r--r--  1 root  wheel   62098 Feb 17 22:58 libtelnet/libtelnet.a
-rw-r--r--  1 root  wheel   66334 Feb 17 22:58 libtelnet/libtelnet_p.a
-rw-r--r--  1 root  wheel   66902 Feb 17 22:58 libtelnet/libtelnet_pic.a

So, why did the libtelnet stuff get updated?

I guess I probably stopped doing domestic builds sometime last year, and then
the remaining files never got removed, and weirdness resulted.