Subject: Re: vi update?
To: Chris G. Demetriou <>
From: Peter Seebach <>
List: current-users
Date: 02/16/2000 14:14:04
In message <>, Chris G. Demetriou writes:
>If i recall, the issues were something like that nvi needed db2,

Not yet, anyway.  nvi-1.79 ships with a self-contained db-1.85 subset.

There are a number of issues you can run into that are caused by the fact
that nvi (at least, the 1.79 I have, and BSD/OS has) does *not* use db2 yet.

>I suggest you look carefully at the license terms on the copy you've

I did indeed.  I have an *old* copy, from November of '96, which I downloaded
when I was playing heat-seeker with new versions of nvi.  I reported a good
10-20 coredump bugs between 1.42 and 1.79.  :)

>* we've fixed the bugs in db1 which people were having problems with,
>maybe nvi 1.79 can actually be used with our db1.

It certainly does 'config' that way.

>* you'll note in the doc/3RDPARTY the note "Bostic says not to update
>from 1.66."  I dunno why it's there (presumably because he said that
>to somebody 8-), but if that's his opinion it's probably a reasonable

It may well be, but I can point out that BSD/OS is using 1.79, and it fixes a
fairly irritating bug.  ;-)

Anyway, I wrote Keith to ask what's up with the licensing.  He may not have
realized that there was a pack-rat with a pre-sleepycat copy of nvi.  :)