Subject: Re: mountd won't export /var/mail
To: Jon Lindgren <>
From: Greywolf <>
List: current-users
Date: 02/14/2000 13:28:29
On Mon, 14 Feb 2000, Jon Lindgren wrote:

# On Mon, 14 Feb 2000, Greywolf wrote:
# > 
# > defender is trying to mount starwolf:/var/mail on /var/mail.  Mount
# > apparently succeeds but accesses to the filesystem return:
# > 
# > 	/var/mail: Input/output error
# > 
# > mountd on starwolf complains:
# > mountd[5329]: "/var/mail", line 8: \
# > 	Can't change attributes for /var/mail to
# <snip>
# Perchance does only the first mount point work?  

No.  All others work fine (after I export the parent directory unless
it's its own filesystem).  I will note that if I do NOT export the parent
first, /usr/share, /export/local and /export/X11 will NOT work.

Something is BROKEN here.  I think I'll go file a pr. :-)

# I ran into a strange
# problem when netbooting a bunch of sparc boxes for install where only the
# first mount point would work... all others give the same "can't change
# attributes" error.  I never really looked into it, and thus never really
# solved it.  Maybe it was tab vs. spaces?  I'm not sure...

Tabs vs. Spaces has no effect.  /holt and /usr/src have a tab and a space on
the line, all others have tabs only.  Go figure.

Another detail:
	defender is running 1.4K.
	starwolf is running 1.4S.

On a version-related note, I submit that our internal numbering scheme is
going to suffer if we surpass Z and go to multichar'd revisions.

Isn't our version represented as

#define __NetBSD_Version__ 104190000

...where it's more or less ("%d%02d%02d%02d00", major, minor, rev, patch),
where rev == (rev_letter - '@')?

Or is this particular #define maintained by hand?

# -Jon
#  --------------------------------------------------------------------
#  "Can you count my penny?" | NetBSD on i386, Alpha, VAX, NeXT, SPARC,
#  "One!"                    | Mac68k, and hopefully more...

NetBSD: priapic OS