Subject: HEADS UP: sendmail 8.9.3 imported
To: None <>
From: Matthias Scheler <>
List: current-users
Date: 02/08/2000 14:49:21

a few minutes ago I finished the import of "sendmail" 8.9.3 into the
NetBSD source tree. The old version 8.8.8 is still available in
"src/usr.sbin/sendmail" but won't be built anymore. It will soon be
turned into a NetBSD package and removed from the main distribution.

Here are few *important* hints for upgrading:

1.) Sendmail 8.8.8 users
    Sendmail 8.9.3 will work fine with your old configuration files. You
    won't however profit from any of the new features. Your sites will
    especially still be vunerable to be abused as mail relay.

2.) Sendmail 8.9.3 users
    - Our "sendmail" 8.9.3 uses TCP wrappers like the old 8.8.8 version.
      Make sure that your "/etc/hosts.allow" permits access to "sendmail"
      or incoming mails will be rejected.
    - Our "sendmail" uses NetBSD's bug fixed DB 1.85 and not 2.7.x. If
      you use e.g. the NetBSD package with "USE_DB2= YES" - this was
      the default some time ago - you must rebuild the databases.

	Kind regards

Matthias Scheler