Subject: Re: FIXED Re: Samba weirdness on -current?
To: None <>
From: Laine Stump <>
List: current-users
Date: 02/03/2000 12:48:30
Bummer - I spoke too soon (but I don't think it's NetBSD's fault).

Previously with December NetBSD and Samba 2.0.3, I could run MS VC++ 6.0 on
a WinNT machine and do batch builds of a large project that lives on a
Samba-exported drive. Now that I'm running yesterday's NetBSD and Samba
2.0.6, VC++ gets several seconds into the build then gives me an "unhandled
exception" somewhere in the VC++ application. Apparently it's getting
something back from the Samba server that it "doesn't like"(tm) and
choosing to croak on it.

So, how do I downgrade pkgsrc back to 2.0.3? Samba's own installation
always keeps around the previous version of binaries so you can revert if
you need to, but when you do "make update" with pkgsrc, it removes all the
old binaries. Is my only hope to figure out the date the supported version
was changed in pkgsrc and do a "cvs update -Dxxx"????

At 11:32 PM 2/2/00 -0500, Laine Stump wrote:
>At 06:14 PM 2/2/00 -0800, Scott Ellis wrote:
>>Samba works now on -current i386.  rsync'ing and rebuilding the kernel and
>>libc solved the problem.
>Working well here, too (well, except that it still doesn't implement all of
>the odd operations that it seems only make a difference when running MS
>applications :-/)