Subject: Re: i386 1.4P hangs randomly?
To: Peter Seebach <>
From: Thilo Manske <Thilo.Manske@HEH.Uni-Oldenburg.DE>
List: current-users
Date: 01/21/2000 07:16:12
On Thu, Jan 20, 2000 at 10:53:43PM -0600, Peter Seebach wrote:
> This is pretty isolated so far, but my laptop is dying under load.
> Symptoms:  System hangs.  I thought this was a panic being ignored
> while I was in X, but I recently got it to happen on console.  No panic
> message.  No debugger.  System just stopped responding to anything, including
> ctl-alt-del.
And did CTRL-ALT-ESC work?
(BTW: What should CTRL-ALT-DEL do? Running zsh I only get a beep
and a ~)

I had something similar yesterday and today again with a kernel made from
sources from Jan 17-18th - it happend during the daily runs. The machine
 was not completely dead, i.e. responded to pings and even received and
forwarded syslog messages and I was able to switch consoles and type
some text there. But I couldn't login, I started the debugger manually,
but didn't found out, what could be wrong,

Today the same, except that I got some messages about "fork: Cannot
allocate memory" and I think "vfork: Cannot..." as well. I jumped
into the debugger, killed one unimportant process (junkbuster), and

Nothing happend. Startet the debugger again and killed setiathome
(wich seemed to be still running - it was the active process) and find
(wich was sleeping I guess since the harddiscs were silent for some time

After I continued the machine paniced immediatly and tried to sync (and
failed).  Savecore didn't find a crashdump after reboot, so I can only tell
from memory that the message was about "kernel ... not enough virtual
memory..." or something like that.

I've tried to reproduce it with the same kernel (starting /etc/daily
manually while looking at top(1)'s output) so I can get crashdump
and some data to fill out a PR but i didn't have any luck so far.

BTW: My previous kernel (dated Jan 13) and the kernels befor didn't have
this problem.

> System has plenty of memory (especially when not running X), and is a PII.
128MByte (more than enough for its tasks), i386 as well (K6-2).
Oh, and no laptop...
Dies ist Thilos Unix Signature! Viel Spass damit.