Subject: Some LFS problems (dumping, fscking)
To: None <>
From: Thilo Manske <Thilo.Manske@HEH.Uni-Oldenburg.DE>
List: current-users
Date: 01/14/2000 11:57:20
I converted one of my filesystems *yesterday* to LFS. I.e. I did
something like dump, edit disklabel/fstab, new_lfs, mount, restore

Now I want to backup parts of it with dump_lfs and get:
  DUMP: Dumping sub files/directories from /home
  DUMP: Dumping file/directory /home/thilo
  DUMP: short read error from /home: [block 8192]: count=8192, got=0
  DUMP: short read error from /home: [sector 8192]: count=1, got=0
  DUMP: short read error from /home: [sector 8193]: count=1, got=0
  DUMP: short read error from /home: [sector 8194]: count=1, got=0
and tons more of them... :-(

Because of that I unmounted /home (just to be sure) and tried to
fsck' it. fsck_lfs told me
"fsck_lfs cannot write to the filesystem yet; the -n flag is required"
so I did a "dry" run with -n wich needed ages and gave me quite a lot

UNREF FILE I=12638  OWNER=root MODE=100555
SIZE=22450 MTIME=Aug 13 12:51 1997
UNREF FILE I=12639  OWNER=root MODE=100555
SIZE=22443 MTIME=Dec 17 03:24 1992

I haven't done much with the filesystem after I filled it up with
the files (restore), especially I had no crash.

architecture: i386
Kernel&Userland fresh NetBSD-current (less than a week old)

The filesystem is
Filesystem          1K-blocks     Used    Avail Capacity  Mounted on
/dev/sd0h             4483072  2776964  1257800    68%    /home
so big and full and as you can see on a SCSI disk. The disk has been
working OK so far with FFS filesystems. It's not mounted with any options.

So what should I do now? tar it up (and convert back to FFS)?

BTW: Does dump_lfs work at all?
On an other system (i386 as well) with a smaller LFS I only use as "scrap space" that
contains just one file I tried dump_lfs as well and it gave me the same errors.
(with different sector numbers of course). I'm going to send in a PR when I'm sure
that this is no pilot-error.
Dies ist Thilos Unix Signature! Viel Spass damit.