Subject: Re: ipnat drops to debugger
To: Laine Stump <>
From: Curt Sampson <>
List: current-users
Date: 01/11/2000 05:00:20
On Tue, 11 Jan 2000, Laine Stump wrote:

> Yup, I am. This is my ipnat config file:
>    map we1 -> proxy port ftp ftp/tcp
>    map we1 -> proxy port 7070 raudio/tcp
>    map we1 -> portmap tcp/udp 10000:65000
>    map we1 ->
> I've never tried it with a /0 instead of /32, did that used to work?

Probably not. That's just a mistake on my part. However, I've fixed
that, the ftp thing, and added the realaudio proxy (which I wish
were documented somewhere).

But I get nowhere near putting any traffic through the thing. In
fact, with binaries built from up-to-date sources, just an ipnat -l
gives me:

    bucolic # ipnat -l
    List of active MAP/Redirect filters:
    kmemcpy:read: Bad address
    kmemcpy: Bad address

I've not done a full install of my build yet, but I'll do that as
soon as it completes and see if I still get this. If I do, I'll go
back to a GENERIC kernel and check it again (not that my kernel
has many changes from GENERIC.)

Curt Sampson  <>   917 532 4208   De gustibus, aut bene aut nihil.
The most widely ported operating system in the world: