Subject: Re: ipnat drops to debugger
To: Curt Sampson <>
From: Laine Stump <>
List: current-users
Date: 01/11/2000 01:33:32
At 01:22 AM 1/11/00 -0500, Curt Sampson wrote:
>On both a mid-December and quite current (a couple of days old) NetBSD
>I find that my system drops to the debugger when I run ipnat on
>the following config file:
>    map we2 -> 0/0 portmap tcp/udp 40000:50000
>    map we2 -> 0/0
>    map we2 -> 0/0 proxy port ftp ftp/tcp
>This is before I've turned on any ipf or packet forwarding. Has
>anyone else seen anything similar? Is anyone running current as of
>the last couple of weeks on an i386 and using ipnat without this

Yup, I am. This is my ipnat config file:

   map we1 -> proxy port ftp ftp/tcp
   map we1 -> proxy port 7070 raudio/tcp
   map we1 -> portmap tcp/udp 10000:65000
   map we1 ->

I've never tried it with a /0 instead of /32, did that used to work?

(This is almost surely unrelated, but note that the ftp proxy won't work
properly unless it is prior to the more generic line in your config file.
You probably only *think* it's working because you're using passive ftp...)

Any idea what traffic is going through when it happens? Or which function?
Given the function, offset within the function, and the instruction, we can
probably figure out which source line the crash is occuring on (it takes
longer than with gdb, but it usually makes sense eventually).