Subject: Re: gifconfig problems
To: None <>
From: Jon Buller <>
List: current-users
Date: 12/30/1999 21:27:31
[ Sorry for the delayed response.  I am not subscribed to current-users.
  I used to be, but my total traffic volume was enough to put my
  mail reading ability past it's limit, so current-users was the
  victim list that got dropped.  Please cc: me on the rest of this
  thread.  Sorry for not stating that in my original message. ]

> Jon, what kind of kernel printf did you get when you did gifconfig?

When I dialup my ISP, I get this:

ppp1: no ifid available for IPv6 link-local address
ppp1: no ifid available for IPv6 link-local address

(I'm not sure why it comes out twice, but I haven't bothered to
look either.)

When I run my 6bone script, I get this:  (I ran the script on the

bullbox# ./6bone
gifconfig: ioctl (SIOCSIFPHYADDR): no such interface
writing to routing socket: File exists
add net default: gateway 3ffe:b00:c18:1fff:0:0:0:41: File exists

Nothing showed up in /var/log/messages, so I assume that there in
no kernel printf that was executed.  My 6bone script just does:

gifconfig $gif inet $me4 $them4
ifconfig $gif inet6 $me6 $them6 prefixlen 127
route add -inet6 default $me6

with appropriate values for all the variables, in case that matters.
And for those that don't know, the (stock) pc532 (like mine) has 8
serial ports and 2 SCSI buses only.  (And one of the SCSI chips
does not have a driver.)  No Ethernet, or anything else that
would provide a serial number or unique ID.