Subject: Re: Using a wheel mouse with X
To: Brett Lymn <>
From: Hubert Feyrer <>
List: current-users
Date: 12/24/1999 14:50:41
On Fri, 24 Dec 1999, Brett Lymn wrote:
>         I lashed out and updated my mouse technology to the late 20th
> century.  My machine now sports a very nice logitech cordless wheel
> mouse.  I am able the use the mouse fine using the opms kernel config
> option (yes, it is a ps/2 style mouse).  In X this makes the mouse
> work as a 3 button mouse which is fine BUT I want more!  I want the
> wheel to work too!  I read the README.mouse in the X11R6 and it said
> they were supported with some provisos so I config'ed up a kernel with
> wscons and rebooted.  The mouse was found as a pmsi (IIRC).  I
> attempted to start up X after saying I had a PS/2 mouse in the
> XF86Config but the cursor skips all over the place indicating I have
> used the wrong protocol.  I tried all the protocol options with no
> success.  The one that sounds correct is the xxxPS/2 protocol but X
> says that my OS does not support that protocol.  I tried grabbing a
> -current copy of the xc from (dated about Dec 14)
> but I still get the same message.  Are there any patches to make this
> work or do I start hacking?

Use the wsmouse protocol. I have the same wireless logitech wheel mouse,
let me know if you got the wheel working. 

 - Hubert

NetBSD - Better for your uptime than Viagra