Subject: Status Report NetBSD on IBM Thinkpad 570 (WARNING: low tech content)
To: None <>
From: Feico Dillema <>
List: current-users
Date: 12/10/1999 01:20:13
I am a happy user of a brand new thinkpad 570. Happy because it's a
very fine machine, but also very much because NetBSD runs so fine
on it. Except for the builtin sound, everything just works, even
hibernation mode (without having to keep a Win'XX partition around).
Installing the latest snapshot was a breeze and let me 
install packages and -current over IPv6 entirely. This saved me
enough time that I could spend on sympathetic nods and apologetic
shrugs to those coworkers insisting on installing their own favorite
OS. Sympathy pains can be a great joy ;). Thanks to you all!

I have some technical comments too that may be of interest to you.
This is not really a problem report, as I don't have anything that
I want/need and doesn't work but I thought you might be interested.

I saw the cardbus support coming into -current recently, and as the
TP570 has a cardbus bridge I compiled a kernel with cardbus support
just to see what would happen. I booted that kernel and the machine
totally hung after detection of the cardbus stuff. Resetting the
machine didn't even work and I needed to powercycle it to get it
running again. So, I guess it was pretty confused. Note that I 
don't have any cardbus cards, just regular PCMCIA cards which work 
just fine with a kernel without cardbus enabled (so this is a non-
issue for me). I'm just reporting this, so that if the author(s)
of the cardbus support would like to look into this, I'd be willing
to build a new cardbus kernel now and then and report what happens
on my machine. I tried this last week of November (NetBSD-1.4P).

I also tried the cnw (Netwave) driver for the first time, which didn't
work because it couldn't allocate enough shared memory at config time.
This was simply fixed by increasing the configured amount of memory
for the pcic in my kernel config, and it works fine now. However,
the boot message `cannot allocate enough mem, will only use i/o mode'
or somehting like that suggested to me that it should work (at
degraded performance?) without, like the awi driver does.  `man cnw'
documents taht i/o mode is not supported, so all this is just
nitpicking on that printf() that suggests it is supported.

More nitpicking: `man cnw' says:

``Note that the driver does not support more-recent device families like 
Netwave AirSurfer ``Plus'', or BayStack 650/660.''

This is true, but might suggest to the reader such cards are not
supported by NetBSD without looking further. As the new awi driver
supports those cards, a reference to it would be nice? (I tried a 
AirSurfer Plus adn this would have fooled me if I hadn't left in the
awi kernel config-entry after using at the last IETF meeting). I'm
not 100% sure whether the Plus card works as I don't have a network
to test against yet, but the awi recognizes it as an AMD 79c930
based card, configures it, I get an awi0 interface and it starts
transmitting frames (blinking tx light), so it looks good so far.

Apologies for the low SNR of this email for this list ;-}, but it's so
nice seeing people around me starting to use NetBSD one after the
other (drank one or two beers tonight too, but...). And I really 
don't advocate it (keeping out of holy OS wars), I just use it ;-)