Subject: Re: disklabeling big disks
To: Bill Squier <>
From: Wolfgang Rupprecht <>
List: current-users
Date: 12/02/1999 18:31:56
Bill Squier writes:
> There's probably a shorter way, but in situations like that, I recall doing:
> 	disklabel -e wd1
> 	:w /tmp/wd1.label (in vi)
> 	quit and answer "n" to re-edit label
> 	disklabel -r -R wd1 /tmp/wd1.label

Thanks for the suggestion.  At this point I've tried so many different 
things that I can't remember exactly which ones I tried and failed at.
I'm fairly sure this was one of the things that was failing though.

I finally blew away the first few megs on the disks with a:
	dd if=/dev/zero of=/dev/rwd1d bs=1024k count=16

Without a valid fdisk/MBR label disklabel worked like a champ.  I then
put the fdisk label back.  I think the problem may have been that I
tried to tell fdisk that my first block was 63 (so as to not overwrite
the mbr) and I told disklabel that my first block was 1008 (the first
cylinder boundary.)  

After attempting to boot from the new disk, it was painfully clear
that I needed to tell both fdisk and disklabel the same start sector.
duh.  I think we can safely say this was pilot error.

Wolfgang Rupprecht    <>
DGPS signals via the Internet