Subject: Re: "Ensoniq" AudioPCI
To: Lennart Augustsson <>
From: Allen Briggs <>
List: current-users
Date: 10/27/1999 19:31:34
> > How different is this from the PR?  I'm using the driver that was
> > in the PR on my system--it seems to work well, except that I can't get
> > it to record anything from the line-in (I haven't tried the microphone
> > and don't have anything connected to the internal jacks).
> It's very similar.  It's just that the AC97 code has been moved to a
> separate file.  And maybe some minute changes.

Well, the one in the PR worked differently for me, but this one doesn't
seem to entirely work either...  ;-)

I get the following on boot:

eap0 at pci0 dev 18 function 0: Ensoniq AudioPCI97 (rev. 0x02)
eap0: interrupting at irq 15
ac97: codec id 0x54524103
ac97: codec features No 3D Stereo
audio0 at eap0: full duplex

When I run xmmix or DAP, the feature-set seems a bit different, and I
don't get any play-through from the line-in port (like I was getting
before).  Playing MP3s with mpg123 does seem to work, though.

Any clues as to where I should start looking for the problems?
I'm not at all familiar with sound drivers...

Note that I'm running 1.4.1 (and 1.4.1-compiled programs) with a
-current kernel on this machine.