Subject: Re: CVS commit: syssrc
To: Johan Danielsson <>
From: Lennart Augustsson <>
List: current-users
Date: 10/15/1999 17:55:25
Johan Danielsson wrote:

> Lennart Augustsson <> writes:
> > Add a number of CARDBUS_CLASS defines.  Copied from PCI_CLASS.
> Is this really what we want to do? CardBus is (mostly) PCI, so does it
> make sense to have two copies of all definitions.

This is not the way I would have done it, but I followed the precedent in
cardbusvar.h which already contained a lot of definitions that were
duplicated from pcireg.h.
Another thing that's wrong is that the file with these definitions is called
cardbusvar.h, and not cardbusreg.h.

There are a number of points where the cardbus code does not follow the
NetBSD coding standards, but I hope they will be fixed now when the code
is in the tree.


        -- Lennart