Subject: anoncvs rsync and cvs weirdnes
To: None <>
From: Mario Kemper <>
List: current-users
Date: 09/26/1999 20:33:45

recently i started to rsync the anoncvs repository because cvs was very slow 
with my modem and i wanted to have the benefits of cvs without always 
going online (telephone costs are high in germany).

So i rsync'ed the repository and then checked it out with:

"cvs -d /src/anoncvs/main checkout src".

The weird thing is, all files have wrong revision and date in the header 
although the source is the head revision: (Makefile is just an example, it 
works with any onther file)

root@bundy:/usr/src#cd /usr/src/
root@bundy:/usr/src#head -1 Makefile 
#       $NetBSD: Makefile,v 1.98 1999/07/12 21:53:52 thorpej Exp $
root@bundy:/usr/src#cvs status Makefile 
File: Makefile          Status: Up-to-date

   Working revision:    1.99    Tue Sep 14 01:32:43 1999
   Repository revision: 1.99    /src/anoncvs/main/basesrc/Makefile,v
   Sticky Tag:          (none)
   Sticky Date:         (none)
   Sticky Options:      (none)

As one can see, the file version is 1.99, but the revision line shows 1.98.
The Makefile itself is current (in this case the dependall changes from the 
1.99 revision are in). And even when i explicitely request the revision 1.99 
cvs update -r 1.99 Makefile

i get the same file.

I tried cvs 1.10 and 1.10.7 (cvs-current) with the same result.

I don't have the slightes idea what happens here.

Mario Kemper