Subject: Recent TADPOLE3GX kernels hang during boot
To: None <,>
From: Todd Whitesel <>
List: current-users
Date: 08/19/1999 00:17:03
August 7th or so I was able to get a -current kernel booting on my Tadpole
3gx by disabling a lot of stuff in the TADPOLE3GX config file. That kernel
(and a fresh userland) worked like a champ all during my week-long vacation
(and I must say the mbrlabel utility is very cool for working with MSDOS
Zip disks).

Since the 17th I have been trying to get a fresh SUP to produce a working
kernel for this machine, but it keeps wanting to hang just after recognizing
the microcontroller (read, it prints "tctrl0 at ..." and then sits there).

Worse, the machine no longer responds to Pause-A after this, and if I try
Pause-O then it prints "tctrl0: SHUTDOWN REQUEST!" but doesn't do anything.

Closing the lid does result in the LCD being powered off, so it's not like
the machine is totally hung, it's just wedged in a less than usable state.
It will respond to changes in battery and external power with more tctrl0:

I tried using a nail to push the reset button, but that doesn't appear to
work (maybe mine is broken?). So I have had to pop the battery in order to
reset the machine the few times I have tried booting a new kernel in the
last day or so.

BTW I am running with a patched rasops8.c file in order to avoid the
undefined 'ri' errors, so it is possible that my real trouble is the
switchover to RASTERCONSOLE.

I also have commented out quite a few of the non-essential items in
TADPOLE3GX, but this has not helped yet. I am trying one last build
now before I give up on today's SUP.

Todd Whitesel
toddpw @