Subject: Re: driver for Lucent WaveLan/IEEE 802.11 committed
To: Christian E. Hopps <>
From: Jeff Rizzo <>
List: current-users
Date: 07/18/1999 11:45:57
On Sun, Jul 18, 1999 at 09:53:24AM -0400, Christian E. Hopps wrote:
> Jeff Rizzo <> writes:
> > 
> > Well, here's my results so far... I can get it to "work" on my ThinkPad 600,
> > by using wiconfig to set the card in BSS mode (as opposed to ad-hoc), but
> > it relatively quickly locks the machine up solid... can't even drop into
> > DDB.  If you've got any suggestions as to how to troubleshoot this,
> > I'm more than happy to help...
> We had problems with my laptop not having enough IO space available.
> The driver requires ~64 bytes of IO space IIRC.  Up to trying this
> driver, my laptop was using a range of IO for the pcmcia cards that was
> partially conflicting with some audio devices (ess maestro).  The IO
> never got mapped/allocated becuase we don't have a driver for this audio
> device.  It hadn't been a problem becuase all the pcmcia cards I was
> using were not adding up enough IO alloction to hit the conflicting
> region.  When we tried the wi it conflicted and the machine would hang.
> To fix this we booted lose98 and verified this was indeed the case, and
> located a larger unused region of unused io space.  To test we did a
> boot -d and in ddb did:
>         w pcic_isa_alloc_iobase 600
>         w pcic_isa_alloc_iosize ff
> That fixed the problem and so I added:
>         options PCIC_ISA_ALLOC_IOBASE=0x600
>         options PCIC_ISA_ALLOC_IOSIZE=0xff
> To my kernel config.
> You may want to look into this, of course the io region will probably be 
> different on your laptop.
> Chris.

Well, this seems to have fixed it, sure enough.  I'm writing this
using the driver even now!

I hope to get a chance to try it out on my Alpha, though last time
I tried any PCMCIA stuff on it (admittedly some time ago), I couldn't
get *anything* to work;  I believe that Jason and others have
fixed some stuff since then, so I'm optimistic.

Incidentally, what is the "approved" way of running generic config
stuff at a specific place in the boot sequence?  I need to run
'wiconfig' before dhclient, so that I can take the interface out of
ad-hoc mode; but if I put it in netstart.local, it gets run *after*
dhclient.  I can obviously hack one of the system rc files (or netstart
itself), but then it's harder to keep up with system file changes...

Thanks again to all involved!

Jeff Rizzo